How to add, remove, check packages and patches in Solaris

In this post we will show you, how we can manage the packages and patches, and what are the command that we will use in order to install or remove them

pkgadd: add a package or packages


#pkgadd -d . LGTOclnt
Processing package instance <LGTOclnt> from </solaris_64>
NetWorker Client(sparc) 7.6.5.0.Build.1160
Copyright (c) 1990-2012, EMC Corporation
This product includes software developed by the University of
California, Berkeley and its contributors.

To setup NetWorker you need to specify a directory to store various
data files in. For a NetWorker client or storage node the default
directory of /var/nsr is acceptable. However, for a NetWorker server,
this directory can become quite large and should reside on a big enough
file system.
Below is a list of file systems which you might consider:
File system              Free space in KB
/oracleASM                        8169757
/oracle_instalador                1368098
/devices                                0
usr/sbin/nwclust.pl
/usr/sbin/nwinstcreate
/usr/sbin/preclntsave <symbolic link>
/usr/sbin/pstclntsave <symbolic link>
/usr/sbin/recover <symbolic link>
/usr/sbin/save <symbolic link>
/usr/sbin/savefs
/usr/sbin/savepnpc
/usr/sbin/uasm
[ verifying class <none> ]
## Executing postinstall script.
Creating the /nsr directory structure
Creating the /nsr/res/servers file
Creating NetWorker start/stop scripts
Adding NetWorker entries to /etc/rpc
Starting the NetWorker daemons
Installation of <LGTOclnt> was successful.

pkgrm: remove a package


#pkgrm LGTOclnt

The following package is currently installed:
   LGTOclnt  NetWorker Client
             (sparc) 7.6.5.0.Build.1160
Do you want to remove this package? [y,n,?,q] y
## Removing installed package instance <LGTOclnt>
This package contains scripts which will be executed with super-user
permission during the process of removing this package.
Do you want to continue with the removal of this package [y,n,?,q] y
## Verifying package <LGTOclnt> dependencies in global zone
## Processing package information.
## Executing preremove script.
Shutting down the NetWorker daemons
## Removing pathnames in class <none>
/usr/sbin/uasm
/usr/sbin/savepnpc
/usr/sbin/savefs
# Executing postremove script.
Removing NetWorker start/stop scripts
Removing NetWorker entries from /etc/rpc
## Updating system information.
Removal of <LGTOclnt> was successful.

pkgchk: verify that any package is correctly installed


-bash-3.2# pkgchk LGTOclnt

pkginfo: show information about packages

-bash-3.2# pkginfo -l LGTOclnt
   PKGINST:  LGTOclnt
      NAME:  NetWorker Client
  CATEGORY:  application
      ARCH:  sparc
   VERSION:  7.6.5.0.Build.1160
   BASEDIR:  /usr
    VENDOR:  EMC Corporation.
      DESC:  NetWorker Client
    PSTAMP:  athletic20121204033833
  INSTDATE:  Sep 23 2015 11:24
   HOTLINE:  Please contact your local service provider
    STATUS:  completely installed
     FILES:       97 installed pathnames
                   7 shared pathnames
                  16 directories
                  68 executables
              426393 blocks used (approx)

pkgparam: show parameter associated to package


bash-3.2# pkgparam LGTOclnt
none
/usr
Sep 23 2015 11:24
yes
/var/nsr
/var/sadm/pkg/LGTOclnt/save
LGTOclnt
athletic20121204033833
false
false
true
Please contact your local service provider
EMC Corporation.
sparc
application
7.6.5.0.Build.1160
NetWorker Client
NetWorker Client
LGTOclnt
/usr/sadm/sysadm
/sbin:/usr/sbin:/usr/bin:/usr/sadm/install/bin


patchadd: add a patch


#patchadd 150400-20

patchrm: remove a patch


#patchrm 150400-20

Comments